top of page

Minimum configuration and prerequisites for Squash TM on a virtual or physical server

Updated: Jun 18, 2021



System requirements:

See what are the minimum and recommended requirements for using Squash

Prerequisites:

  • Operating system: system able to run JVM


Learn more bout operating systems and their Squash-compatible versions

  • Java execution environment: JRE 8 or JRE 11. Java 11 is not compatible with the SAML plugin. JDK 8 and 11 are compatible and supported with Squash TM. A Hotspot JVM is recommended, OpenJ9 can work in some cases but is not officially supported (from Squash TM 1.17, it is MANDATORY to use Java 8, Java 7 is not supported anymore).

  • Application Server: none (Squash TM embeds its own application server: Tomcat)

  • Database: MariaDB 10.5, PostGreSQL 9.6+ (Squash TM is delivered with an embedded database (H2) usable for evaluation purposes. We do not recommend its use in a production context)

  • Recommended components: - Debian Buster - MariaDB 10.5 - Mantis 2.18.x+, Jira 7 (commercial REST plugin) - Apache (web front-end)

Comentários


bottom of page